まぁ、あまり気にしないように。

(ノ・・)ン。。。。。。(((●コロコロッ

1.Apache2のMPMはprefork版を使用する
こちらを参照
http://www.php.net/manual/ja/install.unix.apache2.php

apt-get install apache2-mpm-prefork apache2 apache2-prefork-dev


考察
これってApache1と同じって事?


2.Apache2起動時にPHP5のモジュールでエラーが出る
現象
Apache2を起動すると以下のエラーが出る
/etc/init.d/apache2 start
Syntax error on line 6 of /etc/apache2/httpd.conf:
API module structure `php5_module' in file /usr/lib/apache2/modules/libphp5.so is garbled - perhaps this is not an Apache module DSO?
failed!



原因
PHP5のコンパイルでzend-multibyteを有効にしている

対処
configureオプションの '--enable-zend-multibyte' を撤去

考察
zend-multibyteとは?
PHPのソースコードでSJISを利用するときに必要
・・・いらんな。
ただ、Smartyの<literal>大好き人間は入れた方が良いかもね。プッ。

備考
Apache2.2のソースビルドしたapxsを使った場合はエラーは出ない。
Apache2.2のdebianパッケージが出るまで待つか。




3.phpinfoがいきなり真っ白

現象
php.iniにphp.ini-recommendを使用したときに発生

原因
php.iniの設定short_open_tagディレクティブがデフォルトでOffになっている。

対処
short_open_tag = On
に変更

考察
結構焦る





時間は掛かったが、
思ったよりサックリとインストール完了。
さて、動作や如何に。

コメント








トラックバック
http://dozo.rgr.jp/sb.cgi/450
この記事のトラックバックURL
BlogRanking
オススメしたいグッズ
我の創りし物
カテゴリアーカイブ
banners
loglog
banners
Valid XHTML 1.1!
記事一覧
月別アーカイブ
最近のコメント
最近のトラックバック
リンク
リンク
関連用語
Powered by